Valentine’s Day Week 1


Click the links below to see this week’s event posts.

***Please note not all links will be immediately available***

Main Overview Post
Main Questline – Romeo O Romeo
Who Drops Event Currency This Week
Side Questline – Romeo Peter
Side Questline – Juliet Lois
Side Questline – Apothecary/Friar Quagmire
FaceSpace Sets
Dog Girl/Romantic Thug crashing glitch
Mystery of the Missing Revive Capsules
Addicts Area
Where Are You Now Poll
Tips For Week 2

44 responses to “Valentine’s Day Week 1

  1. I forgot to check for this new event .. missed 2 days .. but I bought Apothecary Quagmire bcz he reminds me of Friar Tuck from Robin Hood and I also love the word “Apothecary” 😀
    heres hoping I unlock Lois & Peter before Wednesday

    Like

  2. Am I the only person finding it easier to collect “rare” poisons than “common” coins? I’ve only had Mort drop coins 3 times. Not a single coin drop from the Mackerel.

    Liked by 1 person

  3. RussianTigger, it appears you’ve responded to one of my comments but it’s not accessible to anyone – as I can only see it on one particular device and no other, probably due to my previous comment (that was a reply to your response to another comment of mine) still awaiting moderation, which means that I can see it as “your comment is awaiting moderation” as long as I stay on this page. I added a small thing as a reply to the comment awaiting moderation, just two minutes later (the longer one posted feb on 14 at 6:53 pm and the short one at 6:55 pm according to what I can see, don’t know if it’s adjusted for local time zones though) and it looks like you’ve moderated that one and the following comment I made as a reply around 2.5 hours later, and subsequently responded to the latter on feb 15 at 6:04 am, to which I’ve now replied with a slightly modified version of the older longer comment not being moderated yet, since the question is basically the same as the one I was replying to in the first place. Realized while searching in here for info on recent issues with other events from another device, that not even the comments that were moderated appeared to be visible, or even your reply to them, unless the whole thing was intentional from your side to keep the conversation invisible to the rest of the forum for some reason? This comment that I’m posting now to make you aware of this can obviously be deleted once it served the purpose of making you aware of the situation, as it doesn’t contain anything useful to anyone else…

    Like

    • All your comments have been pushed through so hopefully anyone else having issues will respond. I did have the nit staying on tasks issue long time ago, but only when using mobile data and not wifi. But this problem seems to pop up now and again for other players. I hope support can look at your game save and see if there’s any issues they can help you with. Let me know.

      Like

  4. Not sure if this was discussed before and I missed it, but is anyone else missing the video fast forward option? I had it during the pizza event but once this one started it disappeared in my game.

    Like

  5. Did anyone else get an option to unlock mercuric joe and start collecting items for him but instead it looks like prison quagmire?

    Like

  6. They really need to fix this. As soon as I complete the first quest, I get the Consuela of death. Probably because I repaired the stations for Romeo Peter and Juliet Lois before I ever got a quest to do so. I’m already bare minimum on the play field. I’m not nuking my town a third time.

    Like

    • I repaired them before I got the quest and not causing any issues. What’s your device details? Maybe it’s struggling to run the game as not getting any other reports of crashing, just the glitch that was fixed last night.

      Like

      • iPhone X plenty of free space if that helps. Latest iOS version. I always keep it up to date. i might have too many characters overall. I’ve put away everyone I can to either Tan Lines or some to storage But most idle characters I just send to the historical society. Had to nuke my town toward the end of the last mini event. Reported it in game. Not sure if they got it because I heard Consuela as I was typing.

        Like

        • Yeah the IPhone X should be able to cope better than your saying. Maybe worth getting your game save checked by Jam City. If you can’t contact them via the In game support panel, you can contact them on their website or via email, derails below.

          Go to their website and use the ‘Contact’ button: https://jamcity.helpshift.com/a/family-guy-the-quest-for-stuff/

          The email address to use is – support@jamcity.com

          Like

          • Thanks. Communication with support is working. Unfortunately despite them pushing a fix that they asked me to restart my device for it’s still happening. Waiting for the next support message. This sucks. Been a player since day one, have all but two skins.

            Like

            • Keep me updated

              Like

              • Latest is I let them know it’s still happening. Just got message that they are working hard on a fix for “an awesome player like you”. I know that’s probably a form letter but it does feel good to know it’s being looked after.

                Like

                • I’m asking about it at this side as well, so fingers crossed. I’ve another player having similar issue, trying get them report it as sometimes more games it’s happening in easier to see the cause and get a fix on it.

                  Like

      • I have the same issue (I think so anyway) where the game says I’ve lost connection, and then most of my progress is gone when I close and reopen the game. I do think this is some real issue and not about low device memory, as the game usually says when my device is low on memory

        Like

        • Have you reported this to Jam City? Does it happen on wifi or cellular?

          Like

          • Haven’t reported it yet, and it appeared to be fixed (as the “lost connection” issue more or less stopped happening) but the progress still isn’t saved properly. It’s strange though, because some progress seem to be saved, but a lot of characters just haven’t gone on the tasks I’ve sent them on. I keep getting a lot of characters sent to the Historical Society Museum just walking around next time I log in, and the ones that were finished in the same building just go back there. Also, the ones I’ve sent on Daily Quests go back to where they came from (Tan Lines in this case) whereas those sent to Tan Lines go right back into the streets of my Quahog. I’m on WiFi but I don’t think that matters. I’m quite sure I’ve tried on mobile as well with the same result. I’ve also checked if there is any real connection error, but that’s definitely not the problem. Going to visit friends doesn’t help saving progress either, as the towns I’ve visited aren’t saved properly either. This all started with the VERY frequent “lost connection” messages though

            Like

            • I didn’t have the other bug at all, if that’s of any significance

              Like

              • And it happened again since my last comment. It’s like I’m being reverted back to a previous save every time. Except now the “connection lost” issue appears to back to some extent

                Like

                • Have you contacted support?

                  Like

                  • Haven’t reported it yet, and it appeared to be fixed for a while (as the “lost connection” issue more or less stopped happening) but progress is till not saved properly. It seems like characters just haven’t gone on the tasks I’ve sent them on. I keep getting the characters that I’ve sent to the Historical Society Museum just walking around next time I log in, and the ones that were finished in the same building just go back there, waiting to be released. Also, the ones I’ve sent on Daily Quests go back to where they came from (Tan Lines in this case) whereas those sent to Tan Lines go right back into the streets of my Quahog. I’m on WiFi but I don’t think that matters. I’m quite sure I’ve tried on mobile as well with the same result. I’ve also checked if there is any real connection error, but that’s definitely not the problem. Going to visit friends doesn’t help saving progress either, as the towns I’ve visited aren’t saved properly either. This all started with the VERY frequent “lost connection” messages though. In many ways this is similar to the disappearance of collected resources for Christmas Gnome Stewie, where each login to the game had us see them reduced no matter what we collected the last time. Instead of added stars for the Historical Society, I’m getting sporadic appearances of the Clam Award pop up that doesn’t really add any clams to the game

                    Like

                    • Update: just finished writing and sending a report to Jam City, so we’ll just have to wait and see what their response is. I’ll report back with any progress on the issue

                      Like

                    • Thanks for doing that, keep me updated

                      Like

                    • Thanks for that info, I’ve one other player having the connection issues on here, he’s playing on an IPhone X. Can I ask what device your using please.

                      Like

            • I’ve replied on other messages, thanks for the info, I’ll ask support if others complaint of the same at this time.

              Like

              • I’m on iPhone 7 and I’ve also tried on iPad Air 2 with the same thing happening there as well.. Doesn’t seem to be device related and it wouldn’t make much sense that this happened if it was. The iPad does have device related issues though, in terms of frequent crashes which means I cannot really keep playing for long on it. That might get better if I’d clear my town of some buildings, but on the other hand it never happens on the iPhone. The iPad held up long enough for the current issue to happen though. I’ve figured out that the current save-point I’m being sent back to every time, is exactly at the end of Friar (Apothecary) Quagmire questline Professor Of Potions part 1, and the beginning of part 2, so the game literally starts with the questline dialog for the ending of part 1 every single time, and I’m not able i any way to progress past that moment. This also means that I restart collecting resources for Juliet Lois and Romeo Peter, as well as unlocking and placing the event buildings and decorations over and over again

                Like

                • One devices I play on is an IPad Air 2 and I have no issues, so sounds like support need to have a look at your game. Hopefully you’ll hear from them after the weekend.

                  Like

  7. Thanks for letting us know about the glitch so fast, RussianTigger 👍

    Like

  8. Thanks for letting us know about the glitch so fast! 👍

    Like

  9. Seems to be a bug when clicking on Dog Girl or Romantic Thug; game crashes with message about Config empty for id vd20_julietLois in Skins.

    Like

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out /  Change )

Google photo

You are commenting using your Google account. Log Out /  Change )

Twitter picture

You are commenting using your Twitter account. Log Out /  Change )

Facebook photo

You are commenting using your Facebook account. Log Out /  Change )

Connecting to %s

This site uses Akismet to reduce spam. Learn how your comment data is processed.