Peter’s Booty Haul Phase 3 – Issues and Answers

With the arrival of Peter’s Booty Haul TinyCo surprised us with a new event area right bang in the middle of our ocean. It looks great but with Phase 3 dropping there’s been some questions being asked over and over, so I wanted to bring you a post where I could answer them for all players to see, as although it’s never nice to have a problem in your game it’s sometimes reassuring knowing others are in the same boat. And thanks to Bunny as usual for taking our issues to TinyCo. The main questions we’re seeing so far are….


Can’t complete Pt. 5 of Punting Treasure as exchanging Oranges for Gunpowder aren’t registering: Getting quite few comments with this and my game was also impacted by it. However Bunny tested in her game and contacted TinyCo and I’m glad to say this issue is sorted. If you go into your game the task should now complete without you having to make another exchange.

UPDATE 9/17 BUNNY: Some Facebook Users are still having issues, they are working on it and hope to get it resolved over the weekend.


Giant Squid hasn’t showed up in my game:  Update 9/17 I know some of you are still having issues with the Giant Squid, please report this to TinyCo through your game, and we will do likewise.

 The Giant Squid will show up at some point before Pt.7 of the main Questline, Punting Treasure, so don’t panic he’s coming to your game soon, we just can’t say how soon. But check as you may be able to earn Broken Oars and Rusty Anchors before he shows up if the tasks that drop them are showing in your game now.

UPDATE 9/17 BUNNY: The Giant Squid it seems should trigger for most Players by Pt. 4 of Treasure Punting. If you do not see the Giant Squid by then, try exiting out of game and restarting your device. If this still does not resolve, please let them know from your game. They are still looking into why a handful of Players are not seeing the Giant Squid. 


Is the Leaderboard live as in my game it shows it is undergoing maintenance: Yes since release of Phase 3 the leaderboards are live, your flags are being counted and you can see your flag total at the top right hand corner of the Leaderboard screen.


Bourbon isn’t dropping: It is an uncommon drop and drop rates seem low, Bunny has raised this with TinyCo.

UPDATE 9/17 BUNNY: I have discussed concerns on many of the drop rates. Hopefully some changes will be coming soon. 🙂


Part 9 of Trawl of Booty won’t complete so can’t move on to Phase 3: Please ensure there isn’t a game update in your app store, you’re looking for Version 1.28.5

UPDATE 9/17 BUNNY: Most devices should have the 1.28.5 Update now (iOS, Google, Kindle). TinyCo is aware that a handful of Facebook Players still have not got it however. It seems Facebook is behind for some reason (similar to when Kindle takes longer to push an update than iOS or Google). TinyCo is doing all they can to try and resolve this over the weekend. Hang in there. They are doing what they can.


Side Note Bunny 9/17: Currently Captain is not voiced in the game. TinyCo is unsure if he will be able to be voiced. (This all goes back to that AMA and licensing availability on items.) Will update if hear anymore on it.

Advertisements

28 responses to “Peter’s Booty Haul Phase 3 – Issues and Answers

  1. I am getting a “Connect Error! Could not connect to server.” error every time I try to get into my game, for the last 1/2 hour. It worked fine from home this morning (about 4 hours ago). I have a good cellular connection, and never use Wi-Fi at the office. Is anyone else seeing this?

    Like

  2. I am also crashing after 1 minute of play. Not sure if it’s water related as I go there immediately because, well, it’s the new phase. I’ve spent money on clams to catch up, and now this???? Slow down tiny co and get it right before an update. This is frustrating beyond belief. The last time this happened, and it happens a lot with this game, I told myself “tinyco can’t be THAT inept, next event will be fine” well guess what. It’s freaking not.

    Like

  3. I can say that mine updated to Phase 3, but still no Giant Squid and I’m already on Part 7 of Treasure Punting, so it tells me to fight the Giant Squid but I can’t. At least, as you said, I can stockpile the Anchors and paddles…

    Like

  4. Still won’t let me start week 3. Everything is done but when I click check back next week – nothing. Playing on phone and have never had problems like this before. Anyone else? Worst part – I used clams to complete pan parts so I wouldn’t get behind.

    Like

  5. Anyone else finding very low drop rates for spare parts when fishing?? So far I’m averaging about 1 from every 12 fish caught. At this rate the event will end before I get the required 32!

    Like

  6. As of right now at midnite, the Part 5 not registering the Oranges exchange is still broken for me on Facebook.

    Like

  7. Has anyone else been having issues with the drop rate for gears in the fishing section? It’s listed as an uncommon drop but it has been dropping at a rate of 1 out of every 8 or 10 for me. That seems MUCH more like a rare drop rate.

    Like

  8. I can do everything except bomb the octopuses. I press fire, it zooms in then freezes. Restart the game and same thing. I’ve been trying all day. I only have 3 items in the water.

    Like

    • Try storing some items out with your water and see if that helps the lag. Close game, restart device and try again. If that doesn’t work have you saved your game to Facebook or email? If so you may want try a clean install. If all that fails you will need contact TinyCo from your game.

      Like

  9. Ariana M Laiche-Oriez

    Here is a fun one- Week 3 has not gone live for Facebook users on PC format, just those with a link to Mobile. What gives?

    Like

  10. Hard to have issues with phase 3 when I can’t get out of phase 2. The elixir of youth stopped dropping three days ago. I’m stuck at 20 and can’t get Pan character. I don’t want to spend 250 clams 10 elixir bottles, to move on. Anyone else stuck? Have over 1200 gold coins and bought all the buildings, Neverland!

    Like

  11. Here’s one for ya! As long as I’m doing things on land I can scroll wherever I want for as long as I want. As soon as I try to scroll over the water, BAM instant crash. So I now can’t do anything with the ship’s or go to the black market cause it just won’t go! Anyone else having this issue?

    Like

    • I’ve not had any issues, anyone else? Have you placed lot decorations in the water?

      Like

      • Not really. Just the required ones. No extra decorations or anything that would clog it up.

        Like

        • What about trying to put some of your land items away? See if that helps? Have you tried close game, restarting your device?

          Like

          • I put away a bunch of things. Didn’t help. Restarted numerous times. Nothing. It was working just fine until the start of phase 3. As long as I’m scrolling around on land it’s fine but as soon as I go out over water it shuts down. I click on the task to build the Boozy Brig and done. Its weird. I messaged tinyco.

            Like

            • Absolutely frustrating when only area you can’t access is where you need to be. If you’ve saved to Facebook or email you could try uninstalling and do a clean install. I don’t know what device you’re on but there was in App Store update when Phase 3 hit, did you do that?

              Like

            • On my kindle, I had to change the graphics in the game settings to the lower setting, then it was fine. I couldn’t scroll over either.

              Like

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s